Scheduled Zoom Software Quarterly Lifecycle Update (5/3/2025)

Scheduled for May 3, 17:00 - 18:00 PDT

Update

We've adjusted the May 2025 version requirements to match those enforced in February 2025. For more information, such as specific versions we are enforcing, refer to the Zoom Software Quarterly Lifecycle Policy support article: https://support.zoomgov.com/hc?id=kb_article_view&sysparm_article=KB0010233
Posted Mar 03, 2025 - 11:06 PST

Scheduled

Zoom will be enforcing a new minimum version of all our Zoom clients and plugins, roughly 90 days from now on May 3, 2025. This affects the following products:
- Zoom app for meetings (Windows, macOS, iOS, Android, and Intune)
- Zoom Rooms (including Zoom Room Controllers)
- Zoom Phone Appliances
- VDI Client and Plugin
- Meetings SDK (Native and Web)
- Video SDK (Web)

Please ensure your devices are updated to the latest version.

For more information, such as specific versions we are enforcing, please see the Zoom Software Quarterly Lifecycle Policy support article: https://support.zoomgov.com/hc?id=kb_article_view&sysparm_article=KB0010233

To assist with checking the client versions on your account, refer to the Dashboard support article for more information: https://support.zoomgov.com/hc?id=kb_article_view&sysparm_article=KB0010592
Posted Feb 03, 2025 - 11:46 PST
This scheduled maintenance affects: Zoom Website (Download Center).